サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
ipv4とipv6のクライアントが混在するOpenVPN
さまざまなクライアントを処理するVPNサーバーがあります。ipv4のみを使用するもの、ipv4とipv6を使用するもの、ipv6のみを使用するものがあります。これらのクライアントの一部はローミングしているため、理想的には、使用可能な場合はipv6に接続し、使用できない場合はipv4にフォールバックする必要があります。 私の現在のセットアップでは、OpenVPNはipv4とipv6をリッスンします: proto udp proto udp6 dev tun 私の最初の質問はここにあります:これはうまくいくようですが、両方のプロトコルを1つの構成ファイルに含めることは安全で正しいですか? 私のクライアントの設定には2つのリモートインスタンスがあります。 remote vpn.domain.tld port udp6 remote vpn.domain.tld port udp 私の質問もここで機能しているようです(失敗した場合は最初にudp6を試すと、udpにフォールバックします)、これはこれを行う良い方法ですか?
11 openvpn  ipv6  ipv4 

4
Haproxyはリクエストをログに記録しませんか?
そこで、ロギングがrsyslogを通過し、今のところすべてが1つのファイルにダンプされるように、Haproxyを構成しました。 起動時にこれらの「開始」メッセージが表示されるため、これは明確にログを記録しますが、HTTP要求はログに記録しません。私の構成の何が問題になっていますか? haproxy.cfg: global log /dev/log local0 debug chroot /var/lib/haproxy stats socket /run/haproxy/admin.sock mode 660 level admin stats timeout 30s user haproxy group haproxy daemon defaults log global mode http option httplog option dontlognull timeout connect 5000 timeout client 50000 timeout server 50000 errorfile 400 /etc/haproxy/errors/400.http errorfile 403 /etc/haproxy/errors/403.http errorfile …

3
CONNECTを使用したSquid HTTPSトンネリングが非常に遅い
ネットワークでイカを使用してコンテンツをキャッシュしています。プロキシを使用するように指示するコマンドラインスイッチを使用してChromeを起動します。 squidは大量のコンテンツをキャッシュし、限られた数のユーザーで正常に動作するため、ほとんどの場合これはうまく機能します。 Chromeを使用したHTTPSのWebサイトにアクセスすると、最初のページの読み込みが非常に遅くなります。Chromeのステータスバーに「プロキシトンネルを待機しています...」と表示されます。ChromeはCONNECT動詞を使用してプロキシをトンネルし、サーバーとのHTTPSを確立します。Chromeは接続を開いたままにしているため、後続のページは高速です。 squid3のログを確認しました。CONNECTエントリの一部を次に示します。2番目の列はミリ秒単位の応答時間です 1416064285.231 2926 192.168.12.10 TCP_MISS/200 0 CONNECT www.google.com:443 - DIRECT/74.125.136.105 - 1416064327.076 49702 192.168.12.10 TCP_MISS/200 1373585 CONNECT r2---sn-q4f7sn7l.googlevideo.com:443 - DIRECT/173.194.141.152 - 1416064345.018 63250 192.168.12.10 TCP_MISS/200 545 CONNECT mtalk.google.com:5228 - DIRECT/74.125.136.188 - 1416064372.020 63038 192.168.12.10 TCP_MISS/200 1809 CONNECT www.facebook.com:443 - DIRECT/31.13.91.2 - 1416064393.040 64218 192.168.12.10 TCP_MISS/200 25346 CONNECT …
11 https  squid 

2
chef-soloとchef-client --local-mode
ドキュメントによると、私はに置き換える必要chef-soloがありchef-client --local-modeます。 ローカルモードは、11.8リリースでchef-clientに追加されました。そのバージョンのchef-client(またはそれ以降)を実行している場合は、chef-soloではなくローカルモードの使用を検討する必要があります。 https://docs.getchef.com/ctl_chef_solo.html コマンドを置き換えるだけで問題なく動作します。2つのコマンドは再構成せずに常に置き換え可能ですか?または、知っておくべきわずかな違いがありますか?
11 chef 

2
外部EEPROMプログラマーを備えたSupermicro BIOSチップの再フラッシュ
私はSupermicroサーバーを使用していますが、保証対象外で、先月自殺しました。はい、正確に。AMIBIOS更新プロセス中に、BIOSウォッチドッグが作動し、フラッシュ中にマザーボードがリセットされました。マザーボードが機能しなくなりました。 BIOSチップがソケットに接続されていないため、マザーボードを修正するためのSOIC8クリップアダプターとTL866 EEPROMプログラマーを持っていますが、問題はここから始まりました。 BIOSチップをフラッシュしようとすると、過電圧保護について不満が出て、チップから読み取ることさえできません。私は動作するボードを持っていて、同じことを試しました:EEPROMチップを読んで、同じ問題が起こります。 問題は、誰かがSupermicro BIOSチップを再フラッシュしたことです。ボードからチップを取り外さずにカスタムプログラマーがチップに書き込むブロックの回路ロックアウトはありますか? 前もって感謝します、
11 bios  supermicro 

1
Bootrec / FIXBOOT vs Bootrec / FIXMBR
Microsoftによると、Bootrec / FIXBOOTの機能は次のとおりです。 "This option writes a new boot sector to the system partition by using a boot sector that's compatible with Windows Vista or Windows 7" そして、これはBootrec / FIXMBRが行うことです: "This option writes a Windows 7 or Windows Vista-compatible MBR to the system partition" MBRは単なる一種のブートセクターではありませんか?他にどのような種類のブートセクターが修正されますか?どちらを使用するのか混乱しています。mbrが唯一のブートセクターウィンドウで使用しているのではないですか?
11 windows  boot  bios  mbr 

1
1つのサーバーでドメインとサブドメインのDNSを実行できますか?
abcとbcの両方のネームサーバーを置き換える必要がある状況があります。2台のマシンをこれに専念する必要はありません。 私はマルチホーミングについて読んでいましたが、すべての例は同じドメインとサブドメインではなく* .bcに対するもののようです。 このシナリオは単一のマシンで可能ですか?
11 bind 

3
ホスト間でSSH公開鍵を配布する
私はAnsibleでいくつかのマシンをセットアップしていて、それらの間のパスワードレス接続を有効にする必要があります。データベースマスターといくつかのスレーブがあります。最初のレプリケーションでは、スレーブはマスターにSSHで接続し、データベースのコピーを取得する必要があります。すべてのスレーブの公開鍵をマスターauthorized_keysファイルに動的に追加するための最良の方法は何ですか。 スレーブの公開鍵を変数として提供し、authorized_keyモジュールを介してそれらを追加することをすでに考えました。しかし、私はキーのリストを維持する必要があります。スレーブグループをもう1つホストに追加するだけで、残りのホストが自動的に機能するアプローチを探しています。 何か案は? 更新: これまでのところ、私は次の擬似コードを取得しました: # collect public keys from slave machines - name: collect slave keys {% for host in groups['databases_slave'] %} shell: /bin/cat /var/lib/postgresql/.ssh/id_rsa.pub register: slave_keys #how to add to an array here? {% endfor %} # Tasks for PostgreSQL master - name: add slave public key sudo: …

2
Amazon-RDSインスタンスのプライベートIPアドレスが見つかりません
マスター/スレーブデータベースアーキテクチャをAmazon RDSに移動しましたが、すべて正常に動作しました。 しかし、私は新しいマスターサーバーと同期を維持する必要があるRDSサービスのスレーブを使用しています。そのためには、マスター(RDS)プライベートアドレスIPでDBドメイン名master-db.myawsserver.comをポイントする必要があります。 AWSコンソールはこの情報を提供せず、MySQLデータベースに直接接続しています。



3
ZFSインポートでプールが見つからない
私はZFSプール-2つのvdevを含むミラー-をFreeBSDサーバーで実行していました。ミラーからディスクを1つだけ取得し、そこからファイルを回復しようとしています。 ZFSデータは、ディスク上のGPTパーティションにあります。 プールをインポートしようとすると、プールがまったく存在する兆候がありません。いくつかの方法を試しましたが、何も起こりません。 私はzdb -luパーティションで実行しましたが、ラベルは問題ないようです。 # zpool import # zpool import -D # zpool status no pools available # zpool import -f ztmp cannot import 'ztmp': no such pool available # zpool import 16827460747202824739 cannot import '16827460747202824739': no such pool available パーティション情報: # gpart list da0 Geom name: da0 modified: …

1
解決可能な名前のSSHクライアントの名前解決が失敗する
jumperいくつかの個別のDMZ内のサーバーにアクセスするために使用されるLinuxボックス(と呼ばれます)があります。各DMZには独自のサブドメイン名(idmz.example.orgなどjdmz.example.org)があり、各サブドメインには独自の権威ネームサーバーがあります。 古いSolarisジャンパーを新しいLinuxボックスに置き換える作業を行っています。ほとんどのことはうまくいきましたが、idmz.example.comSSHを使用したサブドメイン内のサーバーへの接続に問題があります。pingは正常に機能します。を使用して名前をdig解決できますが、SSHは「解決できませんでした」と言います。 名前解決はサーバー側で適切に機能し、IPアドレスを使用して接続すると、遅延やタイムアウトは発生しません。しかし、クライアント側のSSHはサーバーを解決できないと主張しています。 pingおよび失敗したSSH接続: jenny@jumper$ ping server.idmz.example.com PING server.idmz.example.com (192.168.1.3) 56(84) bytes of data. jenny@jumper$ ssh -v server.idmz.example.com OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010 debug1: Reading configuration data /etc/ssh/ssh_config debug1: Applying options for * ssh: Could not resolve hostname server.idmz.example.com: Name or service not known ホスト名の代わりにIPを使用したSSH接続の成功: jenny@jumper$ ssh 192.168.1.3 jenny@192.168.1.3's …

3
2037年に期限切れになるSSL証明書を発行する理由
FirefoxでVerisign Universal Root Certificate Authorityを表示すると、2037年に有効期限が切れていることに気づきました。 (Settingsタブ-> advanced-> view certificates-> VeriSign Universal Root Certification Authority-> View) なぜ23年の寿命があるのですか? なぜ彼らはそれを早く期限切れにしないのですか?または後で?

3
Sendmail:拒否された送信者アドレス(ドメインが見つかりません)
ウェブサーバーでメールを送信する際に問題が発生しています。問題なく送信および配信されるメール(Gmailなど)と、「送信者アドレスが拒否されました:ドメインが見つかりません」で延期されるメールがあります。 これは、送信側ドメインでルックアップが実行されるスパム保護対策であることを理解していますが、ドメインにはMXレコードがあります。 Server: 8.8.8.8 Address: 8.8.8.8#53 Non-authoritative answer: premiumconnect.co.za mail exchanger = 10 za-smtp-2.mimecast.co.za. premiumconnect.co.za mail exchanger = 10 za-smtp-1.mimecast.co.za. Authoritative answers can be found from: (余談ですが、なぜ信頼できる回答がないのですか?それが問題でしょうか?) また、Aレコード: Server: 8.8.8.8 Address: 8.8.8.8#53 Non-authoritative answer: Name: premiumconnect.co.za Address: 196.28.97.202 送信しようとした特定のメールのログは次のとおりです。 Feb 5 12:07:52 premiumconnect sm-mta[2411]: s15C7qYp002411: from=<bookings@premiumconnect.co.za>, size=3522, class=0, nrcpts=1, msgid=<52f22998c2680@premiumconnect.co.za>, …

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.