サーバー管理者

システムおよびネットワーク管理者向けのQ&A

1
Cloudwatch mon-put-instance-dataがAMIクローンインスタンスでレポートしない
(ホストセキュリティグループを変更するために)AMIを使用してEC2インスタンスを複製した後、Amazonが提供するmon-put-instance-data.plスクリプトによって報告された統計がCloudWatchに表示されません。 スクリプトがデータをCloudWatchに報告しているが、CloudWatchコンソールに表示されていないことを確認できます。 # ./mon-put-instance-data.pl --aws-credential-file=/root/.aws-credentials --mem-util --disk-space-util --disk-path=/ --swap-util Successfully reported metrics to CloudWatch. Reference Id: xxxxxxxx-xxxx-xxxx-xxxx-93f25b4efbc7

1
nginx要求行が大きすぎます
エラーが発生しています: Bad Request Request Line is too large (6060 > 4094) 次のようにサーバー上の特定のURLにアクセスすると: /api/categorize?packages=package1,package2,...packageN nginx.confには次のものがあります。 large_client_header_buffers 8 16k; client_header_buffer_size 8k; 特定の問題に関するドキュメントは見つかりません。large_client_header_buffersのドキュメントには400 Bad requestが記載されていますが、「large_client_header_buffers」を4 8kから変更しています。または8 8k; または8 16; 問題を修正しませんでした。
12 nginx  http  web  400 

2
一部のnginxリバースプロキシ設定が1日に1回機能しなくなる
外部のAmazon ELBから内部ELBにリクエストをプロキシするnginxリバースプロキシがあります。 要求を処理する6つのバックエンドインスタンスがあります。サイト対応の構成はこのように見えますが、異なるポート番号とproxy_passがあります。他のすべては同一です: server { listen 3000; location / { proxy_pass http://internal-prod732r8-PrivateE-1GJ070M0745TT-348518554.eu-west-1.elb.amazonaws.com:3000; include /etc/nginx/proxy.conf; } } 24時間ごとに1回、構成の1つが機能しなくなります。他のすべてのプロキシは正常に動作します。nginxを再起動すると、すべての構成が再び機能します。error.logには何も、アクセスログ、syslog、またはdmesgには奇妙なものは何もありません。 これは何か知られていますか?プロキシ設定で何か間違ったことをしましたか?調べることができる他のログはありますか?

1
自身を再起動し続ける強制終了プロセス
Jenkinsプロセスを完全に終了させる方法についてのアドバイスが必要です。それ自体を再起動し続けます。Mac OSXで。 $ps -eaf 216 1143 1 0 0:01.65 ?? 0:04.03 /usr/bin/java -jar /Applications/Jenkins/jenkins.war プロセスを強制終了してみてください... kill 1143 プロセスはまだ別のpidの下に存在します $ps -eaf 216 1175 1 0 0:00.16 ?? 0:01.44 /usr/bin/java -jar /Applications/Jenkins/jenkins.war 親プロセスが起動されます。私は何をしますか? 0 1 0 0 0:06.09 ?? 0:06.19 /sbin/launchd


7
「localhost」を使用してMySQLに接続できませんが、「127.0.0.1」を使用しても問題ありませんか?
/ etc / hostsファイルは次のようになります。 127.0.0.1 localhost # The following lines are desirable for IPv6 capable hosts ::1 ip6-localhost ip6-loopback fe00::0 ip6-localnet ff00::0 ip6-mcastprefix ff02::1 ip6-allnodes ff02::2 ip6-allrouters サーバーの構築中に、ローカルホストに正常にpingできましたが、Postfix、Apache、Dovecotなどのサービスの特定の構成ファイルで、それらを機能させるために127.0.0.1代わりに指定する必要があることがわかりましたlocalhost。 またlocalhost、MySQLへの接続に使用されていた特定のデータベース駆動型Webサイトの構成ファイルを変更する必要がありました。 私はhostsファイルにさまざまな変更を試みましたが、今まで試したことのあるものは何も役に立ちませんでした。 サーバーはUbuntu 12.04.02 LTSを実行しています。selinuxがインストールされておらず、IPtablesのデフォルトポリシーを受け入れてフラッシュするように設定した後でも上記の状況は残ります。

4
Apache2「すべて許可」が機能しない
DebianテストでApache2を新規インストールし、次のようなディレクトリに仮想ホストを構成しました。 <Directory "/path/to/project"> Options Indexes FollowSymLinks MultiViews AllowOverride All Require all granted </Directory> ただし、アクセスすると403 Forbiddenエラーが表示され、エラーログに次のように表示されます。 [Mon Sep 23 22:07:57.249276 2013] [authz_core:debug] [pid 8599] mod_authz_core.c(802): [client 127.0.0.1:49057] AH01626: authorization result of Require all denied: denied [Mon Sep 23 22:07:57.249349 2013] [authz_core:debug] [pid 8599] mod_authz_core.c(802): [client 127.0.0.1:49057] AH01626: authorization result of <RequireAny>: …
12 apache-2.4 

3
バックグラウンドでautosshが機能しない
autossh経由でトンネルを設定しました。 これは動作します: autossh -M 33201 -N -i myIdFile -R 33101:localhost:22 autossh@myhost.com バックグラウンドでautosshを実行したいと思います。-fオプションを使用して簡単に思えます。 ただし、これは機能しません。 autossh -f -M 33201 -N -i myIdFile -R 33101:localhost:22 autossh@myhost.com Autosshはバックグラウンドで正常に実行されますが、ssh接続は毎回失敗するようです。/ var / syslogに次の複数の発生が表示されます。 autossh[3420]: ssh exited with error status 255; restarting ssh 私は何を間違えていますか?ワイルドな推測は、キーファイルを介した認証と関係があることです。これをデバッグするにはどうすればよいですか(sshオプションに-vを追加しても、どこにも記録されないようです)。 編集: -yオプションを使用していくつかのsshログを取得しました /usr/bin/ssh[3484]: debug1: Next authentication method: publickey /usr/bin/ssh[3484]: debug1: Trying private key: …
12 ssh  ssh-tunnel 

4
PostfixでEnvelope Fromを変更するにはどうすればよいですか?
Postfixを使用してAmazon SES経由でメールを送信するLinuxサーバー。Wordpressから電子メールを送信する場合、不適切なEnvelope Fromアドレスが原因で電子メールは拒否されます。 エンベロープ送信元アドレスとして常にmyemail@mydomain.comを使用するようにPostfixを構成するにはどうすればよいですか? コードベースのソリューションではなく、構成可能なデフォルトのプロパティを探しています。

2
Debianでポート転送/リダイレクトを行う方法は?
2つの質問があります。 質問1:私のdebianマシンには、IP 192.168.57.28のインターフェースeth3があります。誰かが192.168.57.28:1234に接続しようとした場合、リクエストを別のマシンにリダイレクトするにはどうすればよいですか:192.168.57.25:80? 質問2:私のdebianマシンに192.168.57.28のeth3といくつかの動的IPのppp0の2つのインターフェースがあり、誰かがポート1234でppp0経由で接続しようとする場合、リクエストを192.168.57.25:80にリダイレクトするにはどうすればよいですか? 私はこれを試しました: $ iptables -t nat -A PREROUTING -p tcp --dport 1234 -j DNAT --to-destination 192.168.57.25:80 $ echo 1 > /proc/sys/net/ipv4/ip_forward しかし、それは機能しません。

2
HAProxyでPOST本体全体を記録しますか?
javascriptクライアントがアプリケーションサーバーとやり取りする方法に関するいくつかの問題を追跡しようとしており、前後に渡されるhttpペイロード全体(ヘッダー、ボディ、およびすべて)を確認したいと考えています。 アプリケーションサーバーの前に既にhaproxyサーバーが存在しているので、関連するログを提供するためにhaproxyを使用できることを望んでいました。実稼働環境でこれをオンにするのは明らかに悪いことですが、このデバッグを行っている間に分離できる環境全体のクローンがあります。 特定のバックエンドサーバーに送信されるPOSTリクエストのhttpペイロード全体をhaproxyに記録させる方法はありますか?
12 haproxy 

1
ネットワークスイッチのデータ転送速度はポートごとまたはデバイスごとに制限されていますか?
ネットワークスイッチが100メガビットまたは1ギガビットなどの速度を報告する場合、それらはイーサネットポートごとの最大速度を指しているのですか、これはすべてのポートのスイッチの物理的な制限ですか?たとえば、ネットワーク上の2人のユーザーが同時に大きなファイルを転送しているとします。100Mbitまたは1 Gbitで互いに競合しますか、それとも最大転送速度に達しますか?

3
Debian「無視」/etc/network/if-pre-up.d/iptables
iptablesルールが起動時に自動的にロードされるようにします。DebianのWikiによると、これはiptablesという名前のスクリプトを/etc/network/if-pre-up.d/に配置することで実行できます。 cat /etc/network/if-pre-up.d/iptables #!/bin/sh /sbin/iptables-restore < /etc/firewall/iptables.rules /sbin/ip6tables-restore < /etc/firewall/ip6tables.rules このスクリプトは機能します。ルートとして実行すると、ファイアウォールルールが適用されます。ただし、再起動時にはファイアウォールルールはありません。私は何を間違えていますか? リクエストに応じて:/ etc / network / interfaces(このファイルには触れませんでした) user@DebianVPS:~$ cat /etc/network/interfaces # This file describes the network interfaces available on your system # and how to activate them. For more information, see interfaces(5). # The loopback network interface auto lo iface …

2
ファイアウォールルールを半分に削減-tcpおよびudpに1つのiptablesルール
私のファイアウォールには、次のようなiptablesルールがいくつかあります。 iptables -A zone_lan_forward -p tcp -d 1.2.3.0/24 -j ACCEPT iptables -A zone_lan_forward -p udp -d 1.2.3.0/24 -j ACCEPT すべてのアドレスに対して、tcp用とudp用の2つのルールを設定するためのショートカットはありますか?私はこのようなことをすることができます: iptables -A zone_lan_forward -p tcp,udp -d 1.2.3.0/24 -j ACCEPT
12 iptables  firewall  tcp  udp 

1
リモートデスクトップを使用して特定のセッションに接続する
我々は持っているWindows 2008 R2すべてのためのアクティブディレクトリ、単一の資格情報を使用してサーバーを。 ログオフせずにセッションから切断することが可能です。 切断されたセッションに直接接続する方法はありSession IDますか? 明確化:tscon良いですが、セッションに直接接続したいです。 現在、必要なセッションが見つかるまですべてにログオンします。

弊社のサイトを使用することにより、あなたは弊社のクッキーポリシーおよびプライバシーポリシーを読み、理解したものとみなされます。
Licensed under cc by-sa 3.0 with attribution required.